blob: 27403418073b8505813136c1c68f0a28d71760cb [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001require xorg-lib-common.inc
2
3# libxpm requires xgettext to build
4inherit gettext
5
6SUMMARY = "Xpm: X Pixmap extension library"
7
8DESCRIPTION = "libXpm provides support and common operation for the XPM \
9pixmap format, which is commonly used in legacy X applications. XPM is \
10an extension of the monochrome XBM bitmap specificied in the X \
11protocol."
12
13LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://COPYING;md5=51f4270b012ecd4ab1a164f5f4ed6cf7"
15DEPENDS += "libxext libsm libxt gettext-native"
16PE = "1"
17
18XORG_PN = "libXpm"
19
20PACKAGES =+ "sxpm cxpm"
21FILES:cxpm = "${bindir}/cxpm"
22FILES:sxpm = "${bindir}/sxpm"
23
24SRC_URI[sha256sum] = "f7eb8f69c039281def8258ae6859adb5f050fbe161ab3d6a2d6ef109a603eac2"
25
26BBCLASSEXTEND = "native"