blob: 716f50ebe16d4938a6fe1abba1edeb5aa0d8322d [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "VA-API support to GStreamer"
2HOMEPAGE = "https://gstreamer.freedesktop.org/"
3DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
4based plugins for GStreamer and helper libraries: `vaapidecode', \
5`vaapiconvert', and `vaapisink'."
6
7REALPN = "gstreamer-vaapi"
8
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
11
12SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz"
13
14SRC_URI[sha256sum] = "510c6fb4ff3f676d7946ce1800e04ccf5aabe5a586d4e164d1961808fab8c94b"
15
16S = "${WORKDIR}/${REALPN}-${PV}"
17DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
18
19inherit meson pkgconfig features_check upstream-version-is-even
20
21REQUIRED_DISTRO_FEATURES ?= "opengl"
22
23EXTRA_OEMESON += " \
24 -Ddoc=disabled \
25 -Dexamples=disabled \
26 -Dtests=enabled \
27"
28
29PACKAGES =+ "${PN}-tests"
30
31# OpenGL packageconfig factored out to make it easy for distros
32# and BSP layers to pick either glx, egl, or no GL. By default,
33# try detecting X11 first, and if found (with OpenGL), use GLX,
34# otherwise try to check if EGL can be used.
35PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
36 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
37 '', d), d)}"
38
39PACKAGECONFIG ??= "drm encoders \
40 ${PACKAGECONFIG_GL} \
41 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
42
43PACKAGECONFIG[drm] = "-Dwith_drm=yes,-Dwith_drm=no,udev libdrm"
44PACKAGECONFIG[egl] = "-Dwith_egl=yes,-Dwith_egl=no,virtual/egl"
45PACKAGECONFIG[encoders] = "-Dwith_encoders=yes,-Dwith_encoders=no"
46PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/libgl"
47PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland wayland-protocols"
48PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxrandr libxrender"
49
50FILES:${PN} += "${libdir}/gstreamer-*/*.so"
51FILES:${PN}-dbg += "${libdir}/gstreamer-*/.debug"
52FILES:${PN}-dev += "${libdir}/gstreamer-*/*.a"
53FILES:${PN}-tests = "${bindir}/*"