blob: b8001f4618b588c85bcc60d995d01d33e3442e1e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Audio format Conversion library"
2DESCRIPTION = "Library for reading and writing files containing sampled \
3sound (such as MS Windows WAV and the Apple/SGI AIFF format) through \
4one standard library interface."
5HOMEPAGE = "https://libsndfile.github.io/libsndfile/"
6AUTHOR = "Erik de Castro Lopo"
7DEPENDS = "flac libogg libvorbis"
8SECTION = "libs/multimedia"
9LICENSE = "LGPL-2.1-only"
10
11SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/libsndfile-${PV}.tar.xz \
12 file://noopus.patch \
13 "
14GITHUB_BASE_URI = "https://github.com/libsndfile/libsndfile/releases/"
15
16SRC_URI[sha256sum] = "0e30e7072f83dc84863e2e55f299175c7e04a5902ae79cfb99d4249ee8f6d60a"
17
18LIC_FILES_CHKSUM = "file://COPYING;md5=e77fe93202736b47c07035910f47974a"
19
20CVE_PRODUCT = "libsndfile"
21
22S = "${WORKDIR}/libsndfile-${PV}"
23
24PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'alsa', d)}"
25PACKAGECONFIG[alsa] = "--enable-alsa,--disable-alsa,alsa-lib"
26PACKAGECONFIG[regtest] = "--enable-sqlite,--disable-sqlite,sqlite3"
27
28inherit autotools lib_package pkgconfig multilib_header github-releases
29
30do_install:append() {
31 oe_multilib_header sndfile.h
32}