blob: 261cb5208166a8a381b5df2d1a0cf3f450fe35e5 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz"
12
13SRC_URI[sha256sum] = "c7a1d9296649233979fa3eacffef3fa024d73d05d589cb622727b5b08c423464"
14
15# exclude betas
16UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17
18# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
19# and 4.3.0 doesn't have the issue
20CVE_CHECK_IGNORE += "CVE-2015-7313"
21# These issues only affect libtiff post-4.3.0 but before 4.4.0,
22# caused by 3079627e and fixed by b4e79bfa.
23CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
24# Issue is in jbig which we don't enable
25CVE_CHECK_IGNORE += "CVE-2022-1210"
26
27inherit autotools multilib_header
28
29CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
30
31PACKAGECONFIG ?= "cxx jpeg zlib lzma \
32 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
33
34PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
35PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
36PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
37PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
38PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
39PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
40
41# Convert single-strip uncompressed images to multiple strips of specified
42# size (default: 8192) to reduce memory usage
43PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
44
45# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
46PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
47
48# Control picking up YCbCr subsample info. Disable to support files lacking
49# the tag
50PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
51
52# Support a mechanism allowing reading large strips (usually one strip files)
53# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
54PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
55
56PACKAGES =+ "tiffxx tiff-utils"
57FILES:tiffxx = "${libdir}/libtiffxx.so.*"
58FILES:tiff-utils = "${bindir}/*"
59
60do_install:append() {
61 oe_multilib_header tiffconf.h
62}
63
64BBCLASSEXTEND = "native nativesdk"