blob: 2b20bdd7b23f2341bb3e6bbaef3311ed612e60e9 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "International Component for Unicode libraries"
2DESCRIPTION = "The International Component for Unicode (ICU) is a mature, \
3portable set of C/C++ and Java libraries for Unicode support, software \
4internationalization (I18N) and globalization (G11N), giving applications the \
5same results on all platforms."
6HOMEPAGE = "http://site.icu-project.org/"
7
8LICENSE = "ICU"
9DEPENDS = "icu-native autoconf-archive"
10DEPENDS:class-native = "autoconf-archive-native"
11
12CVE_PRODUCT = "international_components_for_unicode"
13
14S = "${WORKDIR}/icu/source"
15SPDX_S = "${WORKDIR}/icu"
16STAGING_ICU_DIR_NATIVE = "${STAGING_DATADIR_NATIVE}/${BPN}/${PV}"
17
18ICU_MAJOR_VER = "${@d.getVar('PV').split('-')[0]}"
19
20inherit autotools pkgconfig github-releases
21
22# ICU needs the native build directory as an argument to its --with-cross-build option when
23# cross-compiling. Taken the situation that different builds may share a common sstate-cache
24# into consideration, the native build directory needs to be staged.
25EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE} --disable-icu-config"
26EXTRA_OECONF:class-native = "--disable-icu-config"
27EXTRA_OECONF:class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE} --disable-icu-config"
28
29EXTRA_OECONF:append:class-target = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' --with-data-packaging=archive', '', d)}"
30TARGET_CXXFLAGS:append = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' -DICU_DATA_DIR=\\""${datadir}/${BPN}/${PV}\\""', '', d)}"
31
32ASNEEDED = ""
33
34do_compile:prepend:class-target () {
35 # Make sure certain build host references do not end up being compiled
36 # in the image. This only affects libicutu and icu-dbg
37 sed \
38 -e 's,DU_BUILD=,DU_BUILD_unused=,g' \
39 -e '/^CPPFLAGS.*/ s,--sysroot=${STAGING_DIR_TARGET},,g' \
40 -i ${B}/tools/toolutil/Makefile
41}
42
43PREPROCESS_RELOCATE_DIRS = "${datadir}/${BPN}/${PV}"
44do_install:append:class-native() {
45 mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
46 cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
47 cp -r ${B}/config/icucross.inc ${D}/${STAGING_ICU_DIR_NATIVE}/config
48 cp -r ${B}/lib ${D}/${STAGING_ICU_DIR_NATIVE}
49 cp -r ${B}/bin ${D}/${STAGING_ICU_DIR_NATIVE}
50 cp -r ${B}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
51}
52
53do_install:append:class-target() {
54 # The native pkgdata can not generate the correct data file.
55 # Use icupkg to re-generate it.
56 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
57 rm -f ${D}/${datadir}/${BPN}/${@icu_install_folder(d)}/icudt${ICU_MAJOR_VER}b.dat
58 icupkg -tb ${S}/data/in/icudt${ICU_MAJOR_VER}l.dat ${D}/${datadir}/${BPN}/${@icu_install_folder(d)}/icudt${ICU_MAJOR_VER}b.dat
59 fi
60
61 # Remove build host references...
62 sed -i \
63 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
64 -e 's|${DEBUG_PREFIX_MAP}||g' \
65 -e 's:${HOSTTOOLS_DIR}/::g' \
66 ${D}/${libdir}/${BPN}/${@icu_install_folder(d)}/Makefile.inc \
67 ${D}/${libdir}/${BPN}/${@icu_install_folder(d)}/pkgdata.inc
68}
69
70PACKAGES =+ "libicudata libicuuc libicui18n libicutu libicuio"
71
72FILES:${PN}-dev += "${libdir}/${BPN}/"
73
74FILES:libicudata = "${libdir}/libicudata.so.*"
75FILES:libicuuc = "${libdir}/libicuuc.so.*"
76FILES:libicui18n = "${libdir}/libicui18n.so.*"
77FILES:libicutu = "${libdir}/libicutu.so.*"
78FILES:libicuio = "${libdir}/libicuio.so.*"
79
80BBCLASSEXTEND = "native nativesdk"
81
82LIC_FILES_CHKSUM = "file://../LICENSE;md5=a89d03060ff9c46552434dbd1fe3ed1f"
83
84def icu_download_version(d):
85 pvsplit = d.getVar('PV').split('-')
86 return pvsplit[0] + "_" + pvsplit[1]
87
88def icu_download_folder(d):
89 pvsplit = d.getVar('PV').split('-')
90 return pvsplit[0] + "-" + pvsplit[1]
91
92def icu_install_folder(d):
93 pvsplit = d.getVar('PV').split('-')
94 return pvsplit[0] + "." + pvsplit[1]
95
96ICU_PV = "${@icu_download_version(d)}"
97ICU_FOLDER = "${@icu_download_folder(d)}"
98
99# http://errors.yoctoproject.org/Errors/Details/20486/
100ARM_INSTRUCTION_SET:armv4 = "arm"
101ARM_INSTRUCTION_SET:armv5 = "arm"
102
103BASE_SRC_URI = "${GITHUB_BASE_URI}/download/release-${ICU_FOLDER}/icu4c-${ICU_PV}-src.tgz"
104DATA_SRC_URI = "${GITHUB_BASE_URI}/download/release-${ICU_FOLDER}/icu4c-${ICU_PV}-data.zip"
105SRC_URI = "${BASE_SRC_URI};name=code \
106 ${DATA_SRC_URI};name=data \
107 file://filter.json \
108 file://fix-install-manx.patch \
109 file://0001-icu-Added-armeb-support.patch \
110 "
111
112SRC_URI:append:class-target = "\
113 file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \
114 "
115SRC_URI[code.sha256sum] = "a2d2d38217092a7ed56635e34467f92f976b370e20182ad325edea6681a71d68"
116SRC_URI[data.sha256sum] = "ee19f876507d6c23d9e0a2b631096f6b0eaa6fa61728c33a89efdb55e3385dea"
117
118UPSTREAM_CHECK_REGEX = "releases/tag/release-(?P<pver>(?!.+rc).+)"
119GITHUB_BASE_URI = "https://github.com/unicode-org/icu/releases"
120
121EXTRA_OECONF:append:libc-musl = " ac_cv_func_strtod_l=no"
122
123PACKAGECONFIG ?= ""
124PACKAGECONFIG[make-icudata] = ",,,"
125
126do_make_icudata:class-target () {
127 ${@bb.utils.contains('PACKAGECONFIG', 'make-icudata', '', 'exit 0', d)}
128 cd ${S}
129 rm -rf data
130 cp -a ${WORKDIR}/data .
131 AR='${BUILD_AR}' \
132 CC='${BUILD_CC}' \
133 CPP='${BUILD_CPP}' \
134 CXX='${BUILD_CXX}' \
135 RANLIB='${BUILD_RANLIB}' \
136 CFLAGS='${BUILD_CFLAGS}' \
137 CPPFLAGS='${BUILD_CPPFLAGS}' \
138 CXXFLAGS='${BUILD_CXXFLAGS}' \
139 LDFLAGS='${BUILD_LDFLAGS}' \
140 ICU_DATA_FILTER_FILE=${WORKDIR}/filter.json \
141 ./runConfigureICU Linux --with-data-packaging=archive
142 oe_runmake
143 install -Dm644 ${S}/data/out/icudt${ICU_MAJOR_VER}l.dat ${S}/data/in/icudt${ICU_MAJOR_VER}l.dat
144}
145
146do_make_icudata() {
147 :
148}
149
150addtask make_icudata before do_configure after do_patch do_prepare_recipe_sysroot