blob: dc39693be49cf046f2bd8205a51bf73aadead682 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Easy API to create and parse X.509 and CMS related objects"
2DESCRIPTION = "A library to make the tasks of working with X.509 certificates, \
3CMS data and related objects more easy. It provides a highlevel interface to \
4the implemented protocols and presents the data in a consistent way. The \
5library does not rely on another cryptographic library but provides \
6hooks for easy integration with Libgcrypt. "
7HOMEPAGE = "http://www.gnupg.org/related_software/libksba/"
8LICENSE = "GPL-3.0-or-later & (GPL-2.0-or-later | LGPL-3.0-or-later)"
9LICENSE:${PN} = "GPL-2.0-or-later | LGPL-3.0-or-later"
10LICENSE:${PN}-doc = "GPL-3.0-or-later"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fd541d83f75d038c4e0617b672ed8bda \
12 file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
13 file://COPYING.GPLv3;md5=2f31b266d3440dd7ee50f92cf67d8e6c \
14 file://COPYING.LGPLv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
15 "
16
17DEPENDS = "libgpg-error"
18
19BINCONFIG = "${bindir}/ksba-config"
20
21inherit autotools binconfig-disabled pkgconfig texinfo
22
23UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
24SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
25 file://ksba-add-pkgconfig-support.patch"
26
27SRC_URI[sha256sum] = "3f72c68db30971ebbf14367527719423f0a4d5f8103fc9f4a1c01a9fa440de5c"
28
29do_configure:prepend () {
30 # Else these could be used in preference to those in aclocal-copy
31 rm -f ${S}/m4/gpg-error.m4
32}
33
34BBCLASSEXTEND = "native nativesdk"