blob: fead5c38333da1c783b648d09c0d731472afbed0 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "C library for multiple-precision floating-point computations with exact rounding"
2DESCRIPTION = "The GNU Multiple Precision Floating-Point Reliable Library (GNU MPFR) is a GNU portable C library for arbitrary-precision binary floating-point computation with correct rounding, based on GNU Multi-Precision Library. MPFR's computation is both efficient and has a well-defined semantics: the functions are completely specified on all the possible operands and the results do not depend on the platform."
3HOMEPAGE = "https://www.mpfr.org/"
4LICENSE = "LGPL-3.0-or-later"
5SECTION = "devel"
6
7inherit autotools texinfo
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464 \
10 file://COPYING.LESSER;md5=3000208d539ec061b899bce1d9ce9404 \
11 "
12DEPENDS = "gmp autoconf-archive"
13
14SRC_URI = "https://www.mpfr.org/mpfr-${PV}/mpfr-${PV}.tar.xz"
15SRC_URI[sha256sum] = "06a378df13501248c1b2db5aa977a2c8126ae849a9d9b7be2546fb4a9c26d993"
16
17UPSTREAM_CHECK_URI = "http://www.mpfr.org/mpfr-current/"
18
19BBCLASSEXTEND = "native nativesdk"