blob: b1d8bea790e35dd96f7049baa78f206d03db87aa [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Library for parsing command line options"
2DESCRIPTION = "Popt is a C library for parsing command line parameters. Popt was heavily influenced by the getopt() and getopt_long() functions, but it improves on them by allowing more powerful argument expansion. Popt can parse arbitrary argv[] style arrays and automatically set variables based on command line arguments."
3HOMEPAGE = "https://www.rpm.org/"
4SECTION = "libs"
5
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://COPYING;md5=e0206ac9471d06667e076212db20c5f4"
8
9DEPENDS = "virtual/libiconv"
10
11SRC_URI = "http://ftp.rpm.org/popt/releases/popt-1.x/${BP}.tar.gz \
12 file://run-ptest \
13 "
14SRC_URI[sha256sum] = "c25a4838fc8e4c1c8aacb8bd620edb3084a3d63bf8987fdad3ca2758c63240f9"
15
16inherit autotools gettext ptest
17
18RDEPENDS:${PN}-ptest += "bash"
19
20do_compile_ptest() {
21 sed 's#lt-test1#test1#g' ${S}/tests/testit.sh > ${B}/tests/testit.sh
22}
23
24do_install_ptest() {
25 install ${B}/tests/.libs/test* ${D}/${PTEST_PATH}
26 install ${B}/tests/.libs/tdict ${D}/${PTEST_PATH}
27 install ${B}/tests/testit.sh ${D}/${PTEST_PATH}
28 install ${B}/tests/test-poptrc ${D}/${PTEST_PATH}
29}
30
31BBCLASSEXTEND = "native nativesdk"