blob: 074817df27cb3023df19391cc7e5e5fd7b126600 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001require findutils.inc
2
Andrew Geissler9aee5002022-03-30 16:27:02 +00003# GPL-2.0-or-later (<< 4.2.32), GPL-3.0-or-later (>= 4.2.32)
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00004LICENSE = "GPL-3.0-or-later"
5LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
6
7DEPENDS = "bison-native"
8
9SRC_URI[sha256sum] = "a2bfb8c09d436770edc59f50fa483e785b161a3b7b9d547573cb08065fd462fe"
10
11PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
12# http://savannah.gnu.org/bugs/?27299
13CACHED_CONFIGUREVARS += "gl_cv_func_wcwidth_works=yes"
14
15EXTRA_OECONF += "ac_cv_path_SORT=${bindir}/sort"
16
Andrew Geisslerfc113ea2023-03-31 09:59:46 -050017# need od from coreutils for -t option
18RDEPENDS:${PN}-ptest += "bash sed grep coreutils"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000019
20do_install_ptest:class-target() {
21 mkdir -p ${D}${PTEST_PATH}/tests/
22 cp -r ${S}/tests/* ${D}${PTEST_PATH}/tests/
23
24 # substitute value in run-ptest with actual version
25 sed -i -e 's/__run_ptest_version__/${PV}/' ${D}${PTEST_PATH}/run-ptest
26
27}