blob: e4c590e482bc78db8d3328fd2a6c867f97846830 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "GNOME Display Manager"
2LICENSE="GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5DEPENDS = " \
6 dconf-native \
7 gtk+3 \
8 accountsservice \
9 libcanberra \
10 libpam \
11"
12
Andrew Geissler5199d832021-09-24 16:47:35 -050013REQUIRED_DISTRO_FEATURES = "x11 systemd pam polkit"
Brad Bishope42b3e32020-01-15 22:08:42 -050014
15inherit gnomebase gsettings gobject-introspection gettext systemd useradd upstream-version-is-even features_check
16
Andrew Geisslerbffdb3e2020-08-21 16:13:29 -050017SRC_URI[archive.sha256sum] = "3bfbb620cbc0d1cbd70b4c4376cf4b705db4dc36a37124e5be386ccc25fa7e81"
Brad Bishope42b3e32020-01-15 22:08:42 -050018SRC_URI += "file://0001-Ensure-pam-file-installation.patch"
19
20EXTRA_OECONF = " \
21 --without-plymouth \
22 --with-default-pam-config=openembedded \
23 --with-pam-mod-dir=${base_libdir}/security \
24"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026do_install:append() {
Brad Bishope42b3e32020-01-15 22:08:42 -050027 rm -rf ${D}/run ${D}${localstatedir}/run
28}
29
30USERADD_PACKAGES = "${PN}"
Patrick Williams213cb262021-08-07 19:21:33 -050031USERADD_PARAM:${PN} = "--system --no-create-home --home ${localstatedir}/lib/gdm --user-group gdm"
Brad Bishope42b3e32020-01-15 22:08:42 -050032
Patrick Williams213cb262021-08-07 19:21:33 -050033SYSTEMD_SERVICE:${PN} = "${BPN}.service"
Brad Bishope42b3e32020-01-15 22:08:42 -050034
35# Some gnome components - as gnome-panel and gnome-shell (!!) - require gdm
36# components. To allow gnome-images using different display-manager, split them
37# out into a seperate package.
38PACKAGE_BEFORE_PN = "${PN}-base"
Patrick Williams213cb262021-08-07 19:21:33 -050039FILES:${PN}-base = " \
Brad Bishope42b3e32020-01-15 22:08:42 -050040 ${datadir}/glib-2.0 \
41 ${datadir}/gnome-session \
42 ${libdir}/lib*${SOLIBS} \
43 ${libdir}/girepository-1.0 \
44"
45
Patrick Williams213cb262021-08-07 19:21:33 -050046CONFFILES:${PN} += "${sysconfdir}/gdm/custom.conf"
47FILES:${PN} += " \
Brad Bishope42b3e32020-01-15 22:08:42 -050048 ${datadir}/dconf \
49 ${base_libdir}/security/pam_gdm.so \
50 ${localstatedir} \
51 ${systemd_unitdir} \
52"
53
Patrick Williams213cb262021-08-07 19:21:33 -050054RDEPENDS:${PN} += "${PN}-base"
Brad Bishope42b3e32020-01-15 22:08:42 -050055