blob: bfaeed5fe2ab8069927de63b6b31b038ade15a3b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Lightweight and flexible command-line JSON processor"
2DESCRIPTION = "jq is like sed for JSON data, you can use it to slice and \
3 filter and map and transform structured data with the same \
4 ease that sed, awk, grep and friends let you play with text."
5HOMEPAGE = "https://stedolan.github.io/jq/"
6BUGTRACKER = "https://github.com/stedolan/jq/issues"
7SECTION = "utils"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://COPYING;md5=15d03e360fa7399f76d5a4359fc72cbf"
10
Andrew Geissler82c905d2020-04-13 13:39:40 -050011SRC_URI = "https://github.com/stedolan/${BPN}/releases/download/${BP}/${BP}.tar.gz"
12
13UPSTREAM_CHECK_URI = "https://github.com/stedolan/${BPN}/releases"
14UPSTREAM_CHECK_REGEX = "jq\-(?P<pver>(\d+\.\d+))(?!_\d+).tar.gz"
Brad Bishop19323692019-04-05 15:28:33 -040015
16SRC_URI[md5sum] = "e68fbd6a992e36f1ac48c99bbf825d6b"
17SRC_URI[sha256sum] = "5de8c8e29aaa3fb9cc6b47bb27299f271354ebb72514e3accadc7d38b5bbaa72"
18
19inherit autotools-brokensep
20
21PACKAGECONFIG ?= "oniguruma"
22
23PACKAGECONFIG[docs] = "--enable-docs,--disable-docs,ruby-native"
24PACKAGECONFIG[maintainer-mode] = "--enable-maintainer-mode,--disable-maintainer-mode,flex-native bison-native"
25PACKAGECONFIG[oniguruma] = "--with-oniguruma,--without-oniguruma,onig"
26
27OE_EXTRACONF += " \
28 --disable-valgrind \
29"
30
31BBCLASSEXTEND = "native"