blob: 7325b26e3530034e6a80a684197d9fd82eb7ae2b [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "libblockdev is a C library supporting GObject introspection for manipulation of \
2block devices. It has a plugin-based architecture where each technology (like \
3LVM, Btrfs, MD RAID, Swap,...) is implemented in a separate plugin, possibly \
4with multiple implementations (e.g. using LVM CLI or the new LVM DBus API)."
5HOMEPAGE = "http://rhinstaller.github.io/libblockdev/"
6LICENSE = "LGPLv2+"
7SECTION = "devel/lib"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=c07cb499d259452f324bb90c3067d85c"
10
Andrew Geissler5199d832021-09-24 16:47:35 -050011inherit autotools gobject-introspection pkgconfig
Brad Bishop19323692019-04-05 15:28:33 -040012
Andrew Geissler89770b02020-06-13 10:40:47 -050013SRC_URI = "git://github.com/storaged-project/libblockdev;branch=2.x-branch"
Patrick Williams213cb262021-08-07 19:21:33 -050014SRCREV = "47ff12242c89e36a33259d18b7068b26c3bb1c64"
Brad Bishop19323692019-04-05 15:28:33 -040015S = "${WORKDIR}/git"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017FILES:${PN} += "${libdir}/python2.7/dist-packages ${libdir}/python3.*/site-packages"
Brad Bishop19323692019-04-05 15:28:33 -040018
19PACKAGECONFIG ??= "python3 lvm dm kmod parted fs escrow btrfs crypto mdraid kbd mpath nvdimm"
20PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3"
Brad Bishop0f291cc2019-09-01 15:16:57 -040021PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python"
Brad Bishop19323692019-04-05 15:28:33 -040022PACKAGECONFIG[lvm] = "--with-lvm, --without-lvm, multipath-tools, lvm2"
23PACKAGECONFIG[lvm-dbus] = "--with-lvm_dbus, --without-lvm_dbus, multipath-tools, lvm2"
24PACKAGECONFIG[dm] = "--with-dm, --without-dm, multipath-tools, lvm2"
25PACKAGECONFIG[dmraid] = "--with-dmraid, --without-dmraid"
26PACKAGECONFIG[kmod] = "--with-kbd, --without-kbd, kmod"
27PACKAGECONFIG[parted] = "--with-part, --without-part, parted"
28PACKAGECONFIG[fs] = "--with-fs, --without-fs, util-linux"
29PACKAGECONFIG[doc] = "--with-gtk-doc, --without-gtk-doc, gtk-doc-native"
30PACKAGECONFIG[nvdimm] = "--with-nvdimm, --without-nvdimm, ndctl util-linux"
31PACKAGECONFIG[vdo] = "--with-vdo, --without-vdo"
32PACKAGECONFIG[escrow] = "--with-escrow, --without-escrow, nss volume-key"
33PACKAGECONFIG[btrfs] = "--with-btrfs,--without-btrfs,libbytesize btrfs-tools"
34PACKAGECONFIG[crypto] = "--with-crypto,--without-crypto,cryptsetup nss volume-key"
35PACKAGECONFIG[mdraid] = "--with-mdraid,--without-mdraid,libbytesize"
36PACKAGECONFIG[kbd] = "--with-kbd,--without-kbd,libbytesize"
37PACKAGECONFIG[mpath] = "--with-mpath,--without-mpath, multipath-tools, lvm2"
38
39export GIR_EXTRA_LIBS_PATH="${B}/src/utils/.libs"