blob: cbd45c088db95fc51bc1cd90196a5f0cf8cef4f0 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images"
2DESCRIPTION = "The gd graphics library allows your code to quickly draw images \
3complete with lines, arcs, text, multiple colors, cut and paste from other \
4images, and flood fills, and to write out the result as a PNG or JPEG file. \
5This is particularly useful in Web applications, where PNG and JPEG are two \
6of the formats accepted for inline images by most browsers. Note that gd is not \
7a paint program."
8HOMEPAGE = "http://libgd.github.io/"
9
10SECTION = "libs"
11LICENSE = "GD"
Andrew Geissler5199d832021-09-24 16:47:35 -050012LIC_FILES_CHKSUM = "file://COPYING;md5=ace63adfdac78400fc30fa22ee9c1bb1"
Andrew Geissler82c905d2020-04-13 13:39:40 -050013
14DEPENDS = "freetype libpng jpeg zlib tiff"
15
Andrew Geissler5199d832021-09-24 16:47:35 -050016SRC_URI = "git://github.com/libgd/libgd.git;nobranch=1 \
Andrew Geisslerf103a7f2021-05-07 16:09:40 -050017 "
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
Andrew Geissler5199d832021-09-24 16:47:35 -050019SRCREV = "b5319a41286107b53daa0e08e402aa1819764bdc"
Andrew Geissler82c905d2020-04-13 13:39:40 -050020
21S = "${WORKDIR}/git"
22
23inherit autotools binconfig gettext pkgconfig
24
25EXTRA_OECONF += " --disable-rpath \
26 --with-jpeg=${STAGING_LIBDIR}/.. \
27 --with-freetype=yes \
28 --without-fontconfig \
29 --without-webp \
30 --without-xpm \
31 --without-x \
32 "
33
34EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
35
Patrick Williams213cb262021-08-07 19:21:33 -050036DEBUG_OPTIMIZATION:append = " -Wno-error=maybe-uninitialized"
Andrew Geissler82c905d2020-04-13 13:39:40 -050037
Patrick Williams213cb262021-08-07 19:21:33 -050038do_install:append:class-target() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050039 # cleanup buildpaths from gdlib.pc
40 sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc
41}
42
43PACKAGES += "${PN}-tools"
44
Patrick Williams213cb262021-08-07 19:21:33 -050045FILES:${PN} = "${libdir}/lib*${SOLIBS}"
46FILES:${PN}-tools = "${bindir}/*"
Andrew Geissler82c905d2020-04-13 13:39:40 -050047
48PROVIDES += "${PN}-tools"
Patrick Williams213cb262021-08-07 19:21:33 -050049RPROVIDES:${PN}-tools = "${PN}-tools"
50RDEPENDS:${PN}-tools = "perl perl-module-strict"
Andrew Geissler82c905d2020-04-13 13:39:40 -050051
52CVE_PRODUCT = "libgd"
Andrew Geissler89770b02020-06-13 10:40:47 -050053
54BBCLASSEXTEND = "native nativesdk"