blob: 40cf8bda764e4e5e029863fba901488ebdeb2178 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Python bindings and utilities for GeoJSON"
2HOMEPAGE = "https://pypi.org/project/geojson/"
Andrew Geissler5199d832021-09-24 16:47:35 -05003LICENSE = "BSD-3-Clause"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=f48972abe5cddee79e301574742ed745"
5
6SRC_URI[md5sum] = "14753ed28678828b1de73f68b04e2324"
7SRC_URI[sha256sum] = "6e4bb7ace4226a45d9c8c8b1348b3fc43540658359f93c3f7e03efa9f15f658a"
8
Andrew Geisslerc87764f2020-06-27 00:16:32 -05009inherit pypi setuptools3 ptest
10
11SRC_URI += " \
12 file://run-ptest \
13"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN}-ptest += " \
Andrew Geisslerc87764f2020-06-27 00:16:32 -050016 ${PYTHON_PN}-pytest \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
Andrew Geissler82c905d2020-04-13 13:39:40 -050023
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN} += "python3-simplejson python3-math"
Andrew Geissler82c905d2020-04-13 13:39:40 -050025
26BBCLASSEXTEND = "native nativesdk"