blob: 78a1ef2ac048c2bf213d7f00c35fe66d0634c6e2 [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001DESCRIPTION = "Cryptographic modules for Python."
2HOMEPAGE = "http://www.pycrypto.org/"
3LICENSE = "PSFv2"
4LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
Brad Bishop316dfdd2018-06-25 12:45:53 -04005
Andrew Geisslera2681d92020-10-16 10:17:07 -05006DEPENDS += " gmp"
7
8export HOST_SYS
9
10inherit pypi autotools-brokensep distutils3
11
12SRC_URI += "file://cross-compiling.patch \
13 file://CVE-2013-7459.patch \
14 file://0001-Replace-time.clock-with-time.process_time.patch \
15 "
16
17SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
18SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
19
20do_compile[noexec] = "1"
Andrew Geissler82c905d2020-04-13 13:39:40 -050021
Brad Bishop316dfdd2018-06-25 12:45:53 -040022# We explicitly call distutils_do_install, since we want it to run, but
23# *don't* want the autotools install to run, since this package doesn't
24# provide a "make install" target.
25do_install() {
26 distutils3_do_install
27}
Andrew Geisslera2681d92020-10-16 10:17:07 -050028
29BBCLASSEXTEND = "native nativesdk"