blob: a6100123f9d81e664503eaa29a7b9733932b26ec [file] [log] [blame]
Andrew Geissler5199d832021-09-24 16:47:35 -05001SUMMARY = "Destined to fail"
2LICENSE = "CLOSED"
3
4deltask do_patch
5INHIBIT_DEFAULT_DEPS = "1"
6
7do_shelltest() {
8 echo "This is shell stdout"
9 echo "This is shell stderr" >&2
10 exit 1
11}
12addtask do_shelltest
13
14python do_pythontest_exit () {
15 print("This is python stdout")
16 sys.exit(1)
17}
18addtask do_pythontest_exit
19
20python do_pythontest_fatal () {
21 print("This is python fatal test stdout")
22 bb.fatal("This is a fatal error")
23}
24addtask do_pythontest_fatal