blob: 39317d50e0c68148934bdb6d9de5ed8decaf9f91 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Integrated Development Environment support"
2DESCRIPTION = "Meta package for ensuring the build directory contains all appropriate toolchain packages for using an IDE"
3LICENSE = "MIT"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05004
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005DEPENDS = "virtual/libc gdb-cross-${TARGET_ARCH} qemu-native qemu-helper-native unfs3-native cmake-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006PR = "r3"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05007RM_WORK_EXCLUDE += "${PN}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008
Andrew Geissler5199d832021-09-24 16:47:35 -05009inherit toolchain-scripts nopackages
Patrick Williamsc124f4f2015-09-15 14:41:29 -050010
11do_populate_ide_support () {
12 toolchain_create_tree_env_script
13}
14
Andrew Geissler5199d832021-09-24 16:47:35 -050015python () {
16 sitefiles, searched = siteinfo_get_files(d, sysrootcache=False)
17 d.setVar("CONFIG_SITE", " ".join(sitefiles))
18 d.appendVarFlag("do_populate_ide_support", "file-checksums", " " + " ".join(searched))
19}
20
Patrick Williamsc124f4f2015-09-15 14:41:29 -050021addtask populate_ide_support before do_build after do_install