blob: 6aba65935bfa5cebfbaf06da187f0febae171bcd [file] [log] [blame]
Andrew Geissler5f350902021-07-23 13:09:54 -04001SUMMARY = "XWayland is an X Server that runs under Wayland."
2DESCRIPTION = "XWayland is an X Server running as a Wayland client, \
3and thus is capable of displaying native X11 client applications in a \
4Wayland compositor environment. The goal of XWayland is to facilitate \
5the transition from X Window System to Wayland environments, providing \
6a way to run unported applications in the meantime."
7HOMEPAGE = "https://fedoraproject.org/wiki/Changes/XwaylandStandalone"
8
9LICENSE = "MIT-X"
10LIC_FILES_CHKSUM = "file://COPYING;md5=5df87950af51ac2c5822094553ea1880"
11
12SRC_URI = "https://www.x.org/archive/individual/xserver/xwayland-${PV}.tar.xz"
13SRC_URI[sha256sum] = "b81cbdd5ad60b8b7ad8c3ecc7ec2a28c9bf021448670735cebb501f08bebd18b"
14
15UPSTREAM_CHECK_REGEX = "xwayland-(?P<pver>\d+(\.(?!90\d)\d+)+)\.tar"
16
Andrew Geissler5199d832021-09-24 16:47:35 -050017inherit meson features_check pkgconfig
Andrew Geissler5f350902021-07-23 13:09:54 -040018REQUIRED_DISTRO_FEATURES = "x11 opengl"
19
20DEPENDS += "xorgproto xtrans pixman libxkbfile libxfont2 wayland wayland-native wayland-protocols libdrm libepoxy"
21
22OPENGL_PKGCONFIGS = "glx glamor dri3"
23PACKAGECONFIG ??= "${XORG_CRYPTO} \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '${OPENGL_PKGCONFIGS}', '', d)} \
25"
26PACKAGECONFIG[dri3] = "-Ddri3=true,-Ddri3=false"
27PACKAGECONFIG[glx] = "-Dglx=true,-Dglx=false,virtual/libgl virtual/libx11"
28PACKAGECONFIG[glamor] = "-Dglamor=true,-Dglamor=false,libepoxy virtual/libgbm,libegl"
29PACKAGECONFIG[unwind] = "-Dlibunwind=true,-Dlibunwind=false,libunwind"
30PACKAGECONFIG[xinerama] = "-Dxinerama=true,-Dxinerama=false"
31
32# Xorg requires a SHA1 implementation, pick one
33XORG_CRYPTO ??= "openssl"
34PACKAGECONFIG[openssl] = "-Dsha1=libcrypto,,openssl"
35PACKAGECONFIG[nettle] = "-Dsha1=libnettle,,nettle"
36PACKAGECONFIG[gcrypt] = "-Dsha1=libgcrypt,,libgcrypt"
37
Patrick Williams213cb262021-08-07 19:21:33 -050038do_install:append() {
Andrew Geissler5f350902021-07-23 13:09:54 -040039 # remove files not needed and clashing with xserver-xorg
40 rm -rf ${D}/${libdir}/xorg/
41}
42
Patrick Williams213cb262021-08-07 19:21:33 -050043FILES:${PN} += "${libdir}/xorg/protocol.txt"
Andrew Geissler5f350902021-07-23 13:09:54 -040044