Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Controls the configuration of serial ports" |
| 2 | DESCRIPTION = "setserial is a program designed to set and/or report the configuration information associated with a serial port" |
| 3 | HOMEPAGE = "http://setserial.sourceforge.net" |
| 4 | AUTHOR = "Theodore Ts'o <tytso@mit.edu>" |
| 5 | SECTION = "console/utils" |
| 6 | |
| 7 | LICENSE = "GPLv2.0" |
| 8 | LIC_FILES_CHKSUM = "file://version.h;beginline=1;endline=6;md5=2e7c59cb9e57e356ae81f50f4e4dfd99" |
| 9 | PR = "r3" |
| 10 | |
| 11 | DEPENDS += "groff-native" |
| 12 | |
| 13 | inherit autotools-brokensep |
| 14 | |
| 15 | SRC_URI = "${SOURCEFORGE_MIRROR}/setserial/${BPN}-${PV}.tar.gz \ |
| 16 | file://add_stdlib.patch \ |
| 17 | file://ldflags.patch \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "c4867d72c41564318e0107745eb7a0f2" |
| 21 | SRC_URI[sha256sum] = "7e4487d320ac31558563424189435d396ddf77953bb23111a17a3d1487b5794a" |
| 22 | |
| 23 | do_install() { |
| 24 | install -d ${D}${bindir} |
| 25 | install -d ${D}${mandir}/man8 |
| 26 | |
| 27 | install -m 0755 ${S}/setserial ${D}${bindir} |
| 28 | install -m 0644 ${S}/setserial.8 ${D}${mandir}/man8 |
| 29 | } |