Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "LiSt Open Files tool" |
| 2 | DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \ |
| 3 | Its name stands for LiSt Open Files, and it does just that." |
| 4 | HOMEPAGE = "http://people.freebsd.org/~abe/" |
| 5 | SECTION = "devel" |
| 6 | LICENSE = "Spencer-94" |
| 7 | LIC_FILES_CHKSUM = "file://00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a" |
| 8 | |
| 9 | # Upstream lsof releases are hosted on an ftp server which times out download |
| 10 | # attempts from hosts for which it can not perform a DNS reverse-lookup (See: |
| 11 | # https://people.freebsd.org/~abe/ ). http://www.mirrorservice.org seems to be |
| 12 | # the most commonly used alternative. |
| 13 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 14 | SRC_URI = "git://github.com/lsof-org/lsof;branch=master;protocol=https \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 15 | file://lsof-remove-host-information.patch \ |
| 16 | " |
| 17 | |
| 18 | SRCREV = "005e014e1abdadb2493d8b3ce87b37a2c0a2351d" |
| 19 | |
| 20 | S = "${WORKDIR}/git" |
| 21 | |
| 22 | export LSOF_INCLUDE = "${STAGING_INCDIR}" |
| 23 | |
| 24 | do_configure () { |
| 25 | export LSOF_AR="${AR} cr" |
| 26 | export LSOF_RANLIB="${RANLIB}" |
| 27 | if [ "x${GLIBCVERSION}" != "x" ]; then |
| 28 | LINUX_CLIB=`echo ${GLIBCVERSION} |sed -e 's,\.,,g'` |
| 29 | LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}" |
| 30 | export LINUX_CLIB |
| 31 | fi |
| 32 | yes | ./Configure linux |
| 33 | } |
| 34 | |
| 35 | export I = "${STAGING_INCDIR}" |
| 36 | export L = "${STAGING_INCDIR}" |
| 37 | |
| 38 | do_compile () { |
| 39 | oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}' |
| 40 | } |
| 41 | |
| 42 | do_install () { |
| 43 | install -d ${D}${sbindir} ${D}${mandir}/man8 |
| 44 | install -m 0755 lsof ${D}${sbindir}/lsof |
| 45 | install -m 0644 Lsof.8 ${D}${mandir}/man8/lsof.8 |
| 46 | } |