Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "The extensible, standards compliant build backend used by Hatch" |
| 2 | HOMEPAGE = "https://hatch.pypa.io/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=cbe2fd33fc9297692812fc94b7d27fd9" |
| 5 | |
| 6 | inherit pypi python_hatchling |
| 7 | |
| 8 | DEPENDS += "python3-pluggy-native python3-tomli-native python3-pathspec-native python3-packaging-native python3-editables-native" |
| 9 | DEPENDS:remove:class-native = "python3-hatchling-native" |
| 10 | |
Patrick Williams | 7784c42 | 2022-11-17 07:29:11 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "9f84361f70cf3a7ab9543b0c3ecc64211ed2ba8a606a71eb6a473c1c9b08e1d0" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 12 | |
| 13 | do_compile:prepend() { |
| 14 | export PYTHONPATH=src |
| 15 | } |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |