blob: 04295cd3c6cfdd8e8d11a4e61b7f0baeff2be791 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = ""Compress::Raw::Lzma" provides an interface to the in-memory \
2compression/uncompression functions from the lzma compression library."
3
4SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00005LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Andrew Geissler595f6302022-01-24 19:11:47 +00006
7MAINTAINER= "Poky <poky@yoctoproject.org>"
8HOMEPAGE= "https://metacpan.org/release/Compress-Raw-Lzma"
9
10LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
11file://${COMMON_LICENSE_DIR}/GPL-1.0-only;md5=e9e36a9de734199567a4d769498f743d"
12
13SRC_URI = "https://cpan.metacpan.org/authors/id/P/PM/PMQS/Compress-Raw-Lzma-2.096.tar.gz"
14
15SRC_URI[md5sum] = "b5079bb43712fcd1e74b80777fa376ed"
16SRC_URI[sha256sum] = "f3afb267b1303b0f125976e9e4a70c6a4a205e35e7c99b408911f5e5c6578217"
17
18DEPENDS += "xz"
19
20S = "${WORKDIR}/Compress-Raw-Lzma-${PV}"
21
22inherit cpan
23
24export LIBLZMA_INCLUDE="-I${STAGING_DIR_HOST}${includedir}"
25export LIBLZMA_LIB="-I${STAGING_DIR_HOST}${libdir}"
26
27do_compile() {
28 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
29 cpan_do_compile
30}
31
32BBCLASSEXTEND = "native"