Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Cryptographic modules for Python." |
| 2 | HOMEPAGE = "http://www.pycrypto.org/" |
| 3 | LICENSE = "PSFv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 5 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 6 | DEPENDS += " gmp" |
| 7 | |
| 8 | export HOST_SYS |
| 9 | |
| 10 | inherit pypi autotools-brokensep distutils3 |
| 11 | |
| 12 | SRC_URI += "file://cross-compiling.patch \ |
| 13 | file://CVE-2013-7459.patch \ |
| 14 | file://0001-Replace-time.clock-with-time.process_time.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda" |
| 18 | SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c" |
| 19 | |
| 20 | do_compile[noexec] = "1" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 21 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 22 | # We explicitly call distutils_do_install, since we want it to run, but |
| 23 | # *don't* want the autotools install to run, since this package doesn't |
| 24 | # provide a "make install" target. |
| 25 | do_install() { |
| 26 | distutils3_do_install |
| 27 | } |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |