Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | DESCRIPTION = "LFTP is a sophisticated file transfer program with \ |
| 2 | command line interface. It supports FTP, HTTP, \ |
| 3 | FISH, SFTP, HTTPS and FTPS protocols" |
| 4 | HOMEPAGE = "http://lftp.yar.ru/" |
| 5 | SECTION = "console/network" |
| 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
| 9 | SRC_URI = "http://lftp.yar.ru/ftp/lftp-${PV}.tar.bz2" |
Andrew Geissler | d688a01 | 2020-09-18 13:36:00 -0500 | [diff] [blame] | 10 | SRC_URI[md5sum] = "42ec1793c386702bc2734ffbc8a5cff1" |
| 11 | SRC_URI[sha256sum] = "8a07cbf4df09b107fe3fc41d133ee2f6cea6ef4c33ccf06c8448ad058cd96b7e" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | inherit autotools gettext pkgconfig |
| 14 | |
| 15 | acpaths = "-I ./m4" |
| 16 | |
| 17 | EXTRA_OECONF += "--with-modules --disable-rpath" |
| 18 | |
| 19 | PACKAGECONFIG ??= "openssl zlib gnutls readline expat" |
| 20 | PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl" |
| 21 | PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_INCDIR}/.., --without-zlib, zlib" |
| 22 | PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls" |
| 23 | PACKAGECONFIG[readline] = "--with-readline=${STAGING_INCDIR}/.. --with-readline-inc=${STAGING_INCDIR} --with-readline-lib=-lreadline, --with-readline=no, readline" |
| 24 | PACKAGECONFIG[expat] = "--with-expat=${STAGING_INCDIR}/.. --with-expat-inc=${STAGING_INCDIR} --with-expat-lib=-lexpat, , expat" |
| 25 | |
| 26 | do_install_append() { |
| 27 | rm -rf ${D}${libdir}/charset.alias |
| 28 | } |
| 29 | FILES_${PN} += "${datadir}/icons/hicolor" |
| 30 | FILES_${PN}-dbg += "${libdir}/lftp/${PV}/.debug" |
| 31 | RDEPENDS_${PN} = "perl bash readline" |