blob: 09fa126fe231a4bfef67edd64eeed950ea6bd0f0 [file] [log] [blame]
Artem Senichev8574e7e2020-05-08 12:33:35 +03001SUMMARY = "Command-line interface"
2DESCRIPTION = "YADRO OpenBMC Command Line Interface for end users"
3HOMEPAGE = "https://github.com/YADRO-KNS/obmc-yadro-cli"
4PR = "r1"
5PV = "1.0+git${SRCPV}"
6
7# License info
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
10
11# Dependencies
12DEPENDS = "phosphor-user-manager"
13RDEPENDS_${PN} = "sudo bash"
14
15# Besides executable file we also have shared help
16FILES_${PN} += "${datadir}/cli.help"
17
18# Custom installation procedure
19do_install() {
20 ${B}/install.sh \
21 --dir ${D} \
22 --machine ${MACHINE} \
23 --admin priv-admin \
24 --operator priv-operator \
25 --user priv-user
26}
27
28# Source code repository
29S = "${WORKDIR}/git"
30SRC_URI = "git://github.com/YADRO-KNS/obmc-yadro-cli"
Artem Senicheva183f1e2020-08-03 19:51:15 +030031SRCREV = "5408881b37890968b0a4ada8b35e81454df91321"