blob: 310f71ee647bac4cd311c8ae38fbafd21f8bf17f [file] [log] [blame]
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05301SUMMARY = "OpenPOWER Host checkstop monitor application"
2PR = "r1"
Brad Bishop2879d322018-11-07 14:45:23 -05003LICENSE = "Apache-2.0"
Brad Bishop1ebdb612019-09-13 12:18:25 -04004LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05305
6inherit obmc-phosphor-systemd
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05307inherit allarch
8
Brad Bishop5747dac2022-10-12 17:45:15 -04009DEPENDS += "phosphor-gpio-monitor"
10RDEPENDS:${PN} += "phosphor-gpio-monitor-monitor"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053011
12# For now, monitoring checkstop is the only usecase
13OBMC_HOST_MONITOR_INSTANCES = "checkstop"
14
15# Copies config file having arguments for monitoring host checkstop
16# via GPIO assertion
Patrick Williamse83c2202021-09-01 16:17:33 -050017SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/checkstop"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053018
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053019# This package is not supplying the unit file and also this is not a native
20# recipe since state-mgmt needs this package at runtime. Unsetting this below
21# variable will let the build go through
Adriana Kobylak8c6707f2021-08-06 17:35:36 +000022SYSTEMD_SERVICE:${PN} ?=""
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053023
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053024# Install the override to set up a Conflicts relation
Patrick Williamse83c2202021-09-01 16:17:33 -050025SYSTEMD_OVERRIDE:${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053026
Andrew Geissler5c76e0c2018-03-27 13:56:26 -070027STATES = "startmin"
Vishwanatha Subbannaa1f486e2017-07-26 16:41:03 +053028GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
29GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service"
30CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}"
Patrick Williamse83c2202021-09-01 16:17:33 -050031SYSTEMD_LINK:${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"