blob: aad36e5b2b2d40bd1e1cf006463a69ea9381c98f [file] [log] [blame]
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05301SUMMARY = "Phosphor GPIO monitor application"
2DESCRIPTION = "Application to monitor gpio assertions"
3HOMEPAGE = "http://github.com/openbmc/phosphor-gpio-monitor"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05304LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Patrick Williams4b32c9a2020-03-31 16:43:15 -05006DEPENDS += "sdbusplus"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05307DEPENDS += "phosphor-dbus-interfaces"
Patrick Williams158f5f52017-06-08 08:48:06 -05008DEPENDS += "libevdev"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +05309DEPENDS += "phosphor-logging"
Brad Bishop44f3cce2019-03-22 23:41:42 -040010DEPENDS += "systemd"
Vijay Khemka6890d302019-10-18 18:21:27 -070011DEPENDS += "boost"
12DEPENDS += "libgpiod"
13DEPENDS += "cli11"
14DEPENDS += "nlohmann-json"
Ed Tanous9936f862022-09-19 09:13:20 -070015SRCREV = "629f3e3cd414294ee73bb3946e336f485fe8b504"
16PV = "1.0+git${SRCPV}"
17PR = "r1"
Gunnar Millsb163e9b2017-07-10 15:49:43 -050018
Ed Tanous9936f862022-09-19 09:13:20 -070019SRC_URI += "git://github.com/openbmc/phosphor-gpio-monitor;branch=master;protocol=https"
20
21SYSTEMD_PACKAGES = "${GPIO_PACKAGES}"
Patrick Williams12fc9392021-08-06 09:16:53 -050022SYSTEMD_SERVICE:${PN}-monitor += "phosphor-multi-gpio-monitor.service"
23SYSTEMD_SERVICE:${PN}-monitor += "phosphor-gpio-monitor@.service"
24SYSTEMD_SERVICE:${PN}-presence += "phosphor-gpio-presence@.service"
Ed Tanous9936f862022-09-19 09:13:20 -070025S = "${WORKDIR}/git"
26
27inherit meson pkgconfig
28inherit obmc-phosphor-dbus-service
29
30EXTRA_OEMESON:append = " -Dtests=disabled"
31
Patrick Williams12fc9392021-08-06 09:16:53 -050032FILES:${PN}-monitor += "${bindir}/phosphor-gpio-monitor"
33FILES:${PN}-monitor += "${bindir}/phosphor-multi-gpio-monitor"
34FILES:${PN}-monitor += "${bindir}/phosphor-gpio-util"
Anton Blanchard782d7192021-08-16 23:51:27 -060035FILES:${PN}-monitor += "${nonarch_base_libdir}/udev/rules.d/99-gpio-keys.rules"
Patrick Williams12fc9392021-08-06 09:16:53 -050036FILES:${PN}-presence += "${bindir}/phosphor-gpio-presence"
Vishwanatha Subbanna3de84052017-04-28 15:35:10 +053037
Ed Tanous9936f862022-09-19 09:13:20 -070038ALLOW_EMPTY:${PN} = "1"
William A. Kennington III626c2cf2021-06-04 18:08:38 -070039
Ed Tanous9936f862022-09-19 09:13:20 -070040GPIO_PACKAGES = " \
41 ${PN}-monitor \
42 ${PN}-presence \
43"
44PACKAGE_BEFORE_PN += "${GPIO_PACKAGES}"