blob: fb1480fb12de7758d6312ddd059848490324e434 [file] [log] [blame]
William A. Kennington III580e9c22020-04-13 13:18:11 -07001DESCRIPTION = "phosphor-ipmi-flash config to update without verifying the image"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
4
5inherit systemd
6
7SRC_URI += "file://noverify-bmc-verify.service"
8SRC_URI += "file://config-bmc.json"
9
10SYSTEMD_SERVICE_${PN} += "noverify-bmc-verify.service"
11FILES_${PN} += "${datadir}/phosphor-ipmi-flash/config-bmc.json"
12
13do_install() {
14 install -d ${D}${datadir}/phosphor-ipmi-flash
15 install -m 0644 ${WORKDIR}/config-bmc.json ${D}${datadir}/phosphor-ipmi-flash
16
17 install -d ${D}${systemd_system_unitdir}
18 install -m 0644 ${WORKDIR}/noverify-bmc-verify.service ${D}${systemd_system_unitdir}
19}