blob: 6908c010b5d9203a237ccc903290fdfb2b4d8aab [file] [log] [blame]
Vijay Khemkae810c502019-10-30 10:31:48 -07001SUMMARY = "Chassis Power Control service for Intel based platforms"
2DESCRIPTION = "Chassis Power Control service for Intel based platforms"
3
4SRC_URI = "git://github.com/openbmc/x86-power-control.git;protocol=ssh"
Andrew Geissler5872b4f2020-01-07 02:01:34 +00005SRCREV = "8d6602196d496a8611a789cd36036b2f4ea14f76"
Vijay Khemkae810c502019-10-30 10:31:48 -07006
7PV = "1.0+git${SRCPV}"
8
9S = "${WORKDIR}/git"
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
13
14inherit cmake systemd
15
16SYSTEMD_SERVICE_${PN} += "xyz.openbmc_project.Chassis.Control.Power.service"
17
18DEPENDS += " \
19 boost \
20 i2c-tools \
21 libgpiod \
22 sdbusplus \
23 phosphor-logging \
24 "