blob: b4931d796dd2d0d3b95e10181edafaceb3e4586f [file] [log] [blame]
Brad Bishop23eaf032019-11-20 05:15:02 -05001require ${BPN}.inc
2
3DEPENDS = " \
4 ${BPN}-native intltool-native gperf-native \
Andrew Geissler595f6302022-01-24 19:11:47 +00005 glib-2.0 gtk+3 libgdata libxml2 icu \
Brad Bishop23eaf032019-11-20 05:15:02 -05006 dbus db virtual/libiconv zlib libsoup-2.4 libical nss libsecret \
7"
8
Andrew Geissler595f6302022-01-24 19:11:47 +00009inherit pkgconfig gsettings gobject-introspection features_check cmake gtk-doc gettext perlnative vala
Brad Bishop23eaf032019-11-20 05:15:02 -050010
11REQUIRED_DISTRO_FEATURES = "x11"
12
13SRC_URI += " \
Andrew Geissler9aee5002022-03-30 16:27:02 +000014 file://0001-cmake-Do-not-export-CC-into-gir-compiler.patch \
Brad Bishop23eaf032019-11-20 05:15:02 -050015 file://0001-CMakeLists.txt-Remove-TRY_RUN-for-iconv.patch \
16 file://0002-CMakeLists.txt-remove-CHECK_C_SOURCE_RUNS-check.patch \
17 file://0003-contact-Replace-the-Novell-sample-contact-with-somet.patch \
18 file://0004-call-native-helpers.patch \
19 file://iconv-detect.h \
20"
21
22LKSTRFTIME = "HAVE_LKSTRFTIME=ON"
Patrick Williams213cb262021-08-07 19:21:33 -050023LKSTRFTIME:libc-musl = "HAVE_LKSTRFTIME=OFF"
Brad Bishop23eaf032019-11-20 05:15:02 -050024
Brad Bishop23eaf032019-11-20 05:15:02 -050025EXTRA_OECMAKE = " \
26 -DSYSCONF_INSTALL_DIR=${sysconfdir} \
27 -DWITH_KRB5=OFF \
Andrew Geissler9aee5002022-03-30 16:27:02 +000028 -DENABLE_GOA=OFF \
Brad Bishop23eaf032019-11-20 05:15:02 -050029 -DENABLE_GOOGLE_AUTH=OFF \
30 -DENABLE_WEATHER=OFF \
Andrew Geissler595f6302022-01-24 19:11:47 +000031 -DVAPIGEN=${STAGING_BINDIR_NATIVE}/vapigen \
32 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON -DENABLE_VALA_BINDINGS=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
Brad Bishop23eaf032019-11-20 05:15:02 -050033 -D${LKSTRFTIME} \
34 -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \
35"
36
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000037EXTRA_OECMAKE:append:class-target = " -DG_IR_COMPILER=${STAGING_BINDIR}/g-ir-compiler-wrapper"
38EXTRA_OECMAKE:append:class-target = " -DG_IR_SCANNER=${STAGING_BINDIR}/g-ir-scanner-wrapper"
39
Brad Bishop23eaf032019-11-20 05:15:02 -050040PACKAGECONFIG[canberra] = "-DENABLE_CANBERRA=ON,-DENABLE_CANBERRA=OFF,libcanberra"
41PACKAGECONFIG[oauth] = "-DENABLE_OAUTH2=ON,-DENABLE_OAUTH2=OFF,webkitgtk json-glib"
Andrew Geissler595f6302022-01-24 19:11:47 +000042PACKAGECONFIG[goa] = "-DENABLE_GOA=ON,-DENABLE_GOA=OFF,gnome-online-accounts"
Brad Bishop23eaf032019-11-20 05:15:02 -050043
44# BROKEN: due missing pkg-config in openldap eds' cmake finds host-libs when
45# searching for openldap-libs
46PACKAGECONFIG[openldap] = "-DWITH_OPENLDAP=ON,-DWITH_OPENLDAP=OFF,openldap"
47
48# -ldb needs this on some platforms
49LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0"
50
Patrick Williams58776372022-04-13 09:07:35 -050051# invokes libraries from build host
52GI_DATA_ENABLED:libc-musl="False"
53
Patrick Williams213cb262021-08-07 19:21:33 -050054do_configure:append () {
Brad Bishop23eaf032019-11-20 05:15:02 -050055 cp ${WORKDIR}/iconv-detect.h ${S}/src
Andrew Geissler595f6302022-01-24 19:11:47 +000056 # avoid writing perl-native path into csv2vcard shebang
57 sed -i "s|@PERL@|${bindir}/perl|" ${S}/src/tools/addressbook-export/csv2vcard.in
Brad Bishop23eaf032019-11-20 05:15:02 -050058}
59
Patrick Williams213cb262021-08-07 19:21:33 -050060FILES:${PN} =+ " \
Brad Bishop23eaf032019-11-20 05:15:02 -050061 ${datadir}/dbus-1 \
62 ${datadir}/evolution-data-server-*/ui/ \
63 ${systemd_user_unitdir} \
64"
65
Patrick Williams213cb262021-08-07 19:21:33 -050066RDEPENDS:${PN} += "perl"