blob: f3f4c70fa278ed534d8304987cc856ce638b5efe [file] [log] [blame]
Patrick Williams58776372022-04-13 09:07:35 -05001# SPDX-FileCopyrightText: Huawei Inc.
2#
3# SPDX-License-Identifier: Apache-2.0
4SUMMARY = "OpenThread Daemon is an OpenThread POSIX build mode that runs OpenThread as a service."
5SECTION = "net"
6LICENSE = "BSD-3-Clause & Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=543b6fe90ec5901a683320a36390c65f \
8 file://third_party/mbedtls/repo/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
9 "
10DEPENDS = "readline"
11SRCREV = "7dfde1f12923f03c9680be4d838b94b7a2320324"
12PV = "0.1+git${SRCPV}"
13
14SRC_URI = "git://github.com/openthread/openthread.git;protocol=https;branch=main \
15 "
16
17S = "${WORKDIR}/git"
18
19inherit cmake
20
21EXTRA_OECMAKE = "-DOT_DAEMON=ON \
22 -DOT_SPINEL_RESET_CONNECTION=ON \
23 -DOT_THREAD_VERSION=1.2 \
24 -DOT_COVERAGE=OFF \
25 -DOT_PLATFORM=posix \
26 -DCMAKE_BUILD_TYPE=Release \
27 "