blob: f97a1b899dc5eae2edcc07d124f5fbc50d65d2ec [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Filesystem and hardware benchmark and stress tool"
2DESCRIPTION = "fio is an I/O tool meant to be used both for benchmark and \
3stress/hardware verification. It has support for a number of I/O engines, \
4I/O priorities (for newer Linux kernels), rate I/O, forked or threaded jobs, \
5and much more. It can work on block devices as well as files. fio accepts \
6job descriptions in a simple-to-understand text format. Several example job \
7files are included. fio displays all sorts of I/O performance information."
8HOMEPAGE = "http://freecode.com/projects/fio"
9SECTION = "console/tests"
Andrew Geissler9aee5002022-03-30 16:27:02 +000010LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +000011LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13DEPENDS = "libaio zlib coreutils-native"
14DEPENDS += "${@bb.utils.contains('MACHINE_FEATURES', 'pmem', 'pmdk', '', d)}"
15RDEPENDS:${PN} = "python3-core bash"
16
17PACKAGECONFIG_NUMA = "numa"
18# ARM does not currently support NUMA
19PACKAGECONFIG_NUMA:arm = ""
20PACKAGECONFIG_NUMA:armeb = ""
21
22PACKAGECONFIG ??= "${PACKAGECONFIG_NUMA}"
23PACKAGECONFIG[numa] = ",--disable-numa,numactl"
24
Patrick Williams58776372022-04-13 09:07:35 -050025SRCREV = "a3e48f483db27d20e02cbd81e3a8f18c6c5c50f5"
Andrew Geissler595f6302022-01-24 19:11:47 +000026SRC_URI = "git://git.kernel.dk/fio.git;branch=master \
27"
28
29S = "${WORKDIR}/git"
30
31# avoids build breaks when using no-static-libs.inc
32DISABLE_STATIC = ""
33
34EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
35EXTRA_OECONF = "${@bb.utils.contains('MACHINE_FEATURES', 'x86', '--disable-optimizations', '', d)}"
36
37do_configure() {
38 ./configure ${EXTRA_OECONF}
39}
40
41do_install() {
42 oe_runmake install DESTDIR=${D} prefix=${prefix} mandir=${mandir}
43 install -d ${D}/${docdir}/${PN}
44 cp -R --no-dereference --preserve=mode,links -v ${S}/examples ${D}/${docdir}/${PN}/
45}