blob: 59513bbb9ee15fdb7e746f87489143bb7ecf0ee2 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Hardware identification and configuration data"
2HOMEPAGE = "https://github.com/vcrhonek/hwdata"
3SECTION = "System/Base"
4
5LICENSE = "GPL-2.0-or-later | XFree86-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
7
Patrick Williams58776372022-04-13 09:07:35 -05008SRCREV = "ae144d896eea90e527a57276accaf0da043c9f83"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https"
10S = "${WORKDIR}/git"
11
12inherit allarch
13
14do_configure() {
15 ${S}/configure --datadir=${datadir} --libdir=${libdir}
16}
17
18do_compile[noexec] = "1"
19
20do_install() {
21 oe_runmake install DESTDIR=${D}
22}
23
24FILES:${PN} = "${libdir}/* \
25 ${datadir}/* "