blob: 995f3b779b8eaa3e4421372c3401f5efeb0a7d0c [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "generate GCC code coverage reports"
2HOMEPAGE = "https://gcovr.com"
3SECTION = "devel/python"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=08208c66520e8d69d5367483186d94ed"
6
7SRC_URI = "git://github.com/gcovr/gcovr.git;branch=master;protocol=https"
Patrick Williams58776372022-04-13 09:07:35 -05008SRCREV = "e71e883521b78122c49016eb4e510e6da06c6916"
Andrew Geissler595f6302022-01-24 19:11:47 +00009
10S = "${WORKDIR}/git"
11
12inherit setuptools3
Andrew Geissler9aee5002022-03-30 16:27:02 +000013PIP_INSTALL_PACKAGE = "gcovr"
Andrew Geissler595f6302022-01-24 19:11:47 +000014
15RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments"
16
17BBCLASSEXTEND = "native nativesdk"