blob: 55884e99c21e01a91c742a289348289082cb1e80 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001DESCRIPTION = "Google API client core library"
2HOMEPAGE = "https://github.com/googleapis/python-api-core"
3AUTHOR = "Google LLC"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7inherit pypi setuptools3
8
Patrick Williams58776372022-04-13 09:07:35 -05009SRC_URI[sha256sum] = "b0fa577e512f0c8e063386b974718b8614586a798c5894ed34bedf256d9dae24"
Andrew Geissler595f6302022-01-24 19:11:47 +000010
11RDEPENDS:${PN} += "\
12 ${PYTHON_PN}-asyncio \
13 ${PYTHON_PN}-datetime \
14 ${PYTHON_PN}-logging \
15 ${PYTHON_PN}-math \
16"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-googleapis-common-protos \
20 ${PYTHON_PN}-google-auth \
21 ${PYTHON_PN}-grpcio \
22 ${PYTHON_PN}-protobuf \
23 ${PYTHON_PN}-pytz \
24 ${PYTHON_PN}-requests \
25 ${PYTHON_PN}-six \
26"