blob: 1e919dd3afd5e7e0bad65ff0d5aea6826c8efa4c [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Google gRPC tools"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=7145f7cdd263359b62d342a02f005515"
7
8inherit pypi setuptools3
9
10DEPENDS += "${PYTHON_PN}-grpcio"
11
12SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
Patrick Williams58776372022-04-13 09:07:35 -050013SRC_URI[sha256sum] = "a016cfc21e0d91b3b036d3d4f968d1fdea865dfa03524cb1fbeca84719fd45a2"
Andrew Geissler9aee5002022-03-30 16:27:02 +000014
15RDEPENDS:${PN} = "${PYTHON_PN}-grpcio"
16
17BBCLASSEXTEND = "native nativesdk"