blob: 724bbd7f73af44d5c3ca840e6e80526abee8d188 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "Python project template generator with batteries included"
2DESCRIPTION = "PyScaffold package helps to setup a new Python project. \
3After installation, it provides a new command [putup], which could be \
4used to create template Projects."
5
6HOMEPAGE = "https://github.com/pyscaffold/pyscaffold"
7SECTION = "devel/python"
8LICENSE = "0BSD & MIT"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=14a49c74a1d91829908ac756c07e6b91"
10DEPENDS += "python3-setuptools-scm-native"
11
Patrick Williams58776372022-04-13 09:07:35 -050012SRC_URI[sha256sum] = "c8cfa9983503f31b301f4b0bec0a8f41518f9a3a3853471ce94f9f9dc770a3e2"
Andrew Geissler9aee5002022-03-30 16:27:02 +000013
14inherit pypi python_setuptools_build_meta
15PYPI_PACKAGE = "PyScaffold"
16
17RDEPENDS:${PN} += " \
18 python3-email \
19 python3-compression \
20"
21
22BBCLASSEXTEND = "native nativesdk"