blob: 6c1bf7e82ce5258dbf26633f1e0fb9f8c15ccca5 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Ultra fast JSON encoder and decoder for Python"
2DESCRIPTION = "UltraJSON is an ultra fast JSON encoder and decoder written in pure C with bindings for Python 2.5+ and 3."
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=10fa10456417c0252bcb8a498e498ffe"
6
7SRC_URI[sha256sum] = "a88944d2f99db71a3ca0c63d81f37e55b660edde0b07216fb65a3e46403ef004"
8
9inherit pypi ptest setuptools3
10
11SRC_URI += " \
12 file://run-ptest \
13 file://0001-setup.py-Do-not-strip-debugging-symbols.patch \
14"
15
16DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
17
18RDEPENDS:${PN} += "\
19 ${PYTHON_PN}-datetime \
20 ${PYTHON_PN}-numbers \
21"
22
23RDEPENDS:${PN}-ptest += " \
24 ${PYTHON_PN}-json \
25 ${PYTHON_PN}-pytest \
26 ${PYTHON_PN}-pytz \
27"
28
29do_install_ptest() {
30 install -d ${D}${PTEST_PATH}/tests
31 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
32}
33
34BBCLASSEXTEND = "native nativesdk"