blob: 3fc8450513a438df1e053f52530f6f5a50e7042e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A UPnP AV media server and renderer"
2DESCRIPTION = "Rygel is a home media solution (UPnP AV MediaServer) that \
3allow you to easily share audio, video and pictures to other devices. \
4Additionally, media player software may use Rygel to become a MediaRenderer \
5that may be controlled remotely by a UPnP or DLNA Controller."
6HOMEPAGE = "http://live.gnome.org/Rygel"
7
8LICENSE = "LGPL-2.1"
9LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
10
11DEPENDS = "libxml2 glib-2.0 gssdp gupnp gupnp-av gupnp-dlna gstreamer1.0 gstreamer1.0-plugins-base libgee libsoup-2.4 libmediaart-2.0 libunistring sqlite3 intltool-native"
12RDEPENDS_${PN} = "gstreamer1.0-plugins-base-playback shared-mime-info"
13RRECOMMENDS_${PN} = "rygel-plugin-media-export"
14
15inherit gnomebase vala gobject-introspection gettext systemd
16
17SRC_URI[archive.md5sum] = "7f95401903a3f855b464d5152b9d4c07"
18SRC_URI[archive.sha256sum] = "08c21a577f7bdad26446a75ffa32778b26842c3b1188165f0b19818559747d00"
19
20EXTRA_OECONF = "--disable-tracker-plugin --with-media-engine=gstreamer"
21
22PACKAGECONFIG ?= "external mpris ruih media-export gst-launch"
23
24PACKAGECONFIG_append = "${@bb.utils.contains("DISTRO_FEATURES", "x11", " gtk+3", "", d)}"
25
26PACKAGECONFIG[external] = "--enable-external-plugin,--disable-external-plugin"
27PACKAGECONFIG[mpris] = "--enable-mpris-plugin,--disable-mpris-plugin"
28PACKAGECONFIG[ruih] = "--enable-ruih-plugin,--disable-ruih-plugin"
29PACKAGECONFIG[media-export] = "--enable-media-export-plugin,--disable-media-export-plugin"
30PACKAGECONFIG[gst-launch] = "--enable-gst-launch-plugin,--disable-gst-launch-plugin"
31PACKAGECONFIG[gtk+3] = ",--without-ui,gtk+3"
32PACKAGECONFIG[lms] = "--enable-lms-plugin,--disable-lms-plugin"
33
34LIBV = "2.6"
35
36do_install_append() {
37 # Remove .la files for loadable modules
38 rm -f ${D}/${libdir}/rygel-${LIBV}/engines/*.la
39 rm -f ${D}/${libdir}/rygel-${LIBV}/plugins/*.la
40 if [ -e ${D}${nonarch_libdir}/systemd/user/rygel.service ]; then
41 mkdir -p ${D}${systemd_unitdir}/system
42 mv ${D}${nonarch_libdir}/systemd/user/rygel.service ${D}${systemd_unitdir}/system
43 rmdir --ignore-fail-on-non-empty ${D}${nonarch_libdir}/systemd/user \
44 ${D}${nonarch_libdir}/systemd \
45 ${D}${nonarch_libdir}
46 fi
47}
48
49FILES_${PN} += "${libdir}/rygel-${LIBV}/engines ${datadir}/dbus-1 ${datadir}/icons"
50FILES_${PN}-dbg += "${libdir}/rygel-${LIBV}/engines/.debug ${libdir}/rygel-${LIBV}/plugins/.debug"
51
52PACKAGES += "${PN}-meta"
53ALLOW_EMPTY_${PN}-meta = "1"
54
55PACKAGES_DYNAMIC = "${PN}-plugin-*"
56
57SYSTEMD_SERVICE_${PN} = "rygel.service"
58
59python populate_packages_prepend () {
60 rygel_libdir = d.expand('${libdir}/rygel-${LIBV}')
61 postinst = d.getVar('plugin_postinst')
62 pkgs = []
63
64 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), 'librygel-(.*)\.so$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
65 pkgs += do_split_packages(d, oe.path.join(rygel_libdir, "plugins"), '(.*)\.plugin$', d.expand('${PN}-plugin-%s'), 'Rygel plugin for %s', postinst=postinst, extra_depends=d.expand('${PN}'))
66
67 metapkg = d.getVar('PN') + '-meta'
68 d.setVar('RDEPENDS_' + metapkg, ' '.join(pkgs))
69}