blob: ca65114c4d0cf435a3443bb75a28135452fe06b8 [file] [log] [blame]
Brad Bishop868407c2019-11-04 13:24:47 -05001require ${BPN}.inc
2
3inherit native
4
5DEPENDS += " \
6 glib-2.0-native \
7 dbus-native \
8 iso-codes \
9"
10
11PACKAGECONFIG = ""
12
13# for allarch iso-codes
14EXTRA_NATIVE_PKGCONFIG_PATH = ":${RECIPE_SYSROOT}${datadir_native}/pkgconfig"
15# for allarch unicode-ucd - just to make configure happy
16EXTRA_OECONF += "--with-ucd-dir=${RECIPE_SYSROOT}${datadir_native}/unicode/ucd"
17
18do_compile() {
19 cd src
20 # seems by moving to src we break dependency tracking so build what's
21 # necessary step by step
22 oe_runmake ibusenumtypes.h
23 oe_runmake ibusmarshalers.h
24 oe_runmake ibusenumtypes.c
25 oe_runmake unicode-parser
26}
27
28do_install() {
29 install -d ${D}/${libdir}
30 install -m 755 ${S}/src/.libs/libibus-*.so* ${D}/${libdir}
31
32 install -d ${D}/${bindir}
33 install -m 755 ${S}/src/.libs/unicode-parser ${D}/${bindir}
34}