blob: 92999255b6fe8b853daf3ca206d76b02eadd4986 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "MessagePack (de)serializer"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
4
5PYPI_PACKAGE = "msgpack"
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "51fdc7fb93615286428ee7758cecc2f374d5ff363bdd884c7ea622a7a327a81e"
9
10RDEPENDS:${PN}:class-target += "\
11 ${PYTHON_PN}-io \
12"
13
14BBCLASSEXTEND = "native nativesdk"
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-pytest \
22"
23
24do_install_ptest() {
25 install -d ${D}${PTEST_PATH}/test
26 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
27}