Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame^] | 1 | SUMMARY = "Python WBEM Client and Provider Interface" |
| 2 | DESCRIPTION = "\ |
| 3 | A Python library for making CIM (Common Information Model) operations over \ |
| 4 | HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \ |
| 5 | WBEM client should be easy to use and not necessarily require a large amount \ |
| 6 | of programming knowledge. It is suitable for a large range of tasks from \ |
| 7 | simply poking around to writing web and GUI applications. \ |
| 8 | \ |
| 9 | WBEM, or Web Based Enterprise Management is a manageability protocol, like \ |
| 10 | SNMP, standardised by the Distributed Management Task Force (DMTF) available \ |
| 11 | at http://www.dmtf.org/standards/wbem. \ |
| 12 | \ |
| 13 | It also provides a Python provider interface, and is the fastest and easiest \ |
| 14 | way to write providers on the planet." |
| 15 | HOMEPAGE = "http://pywbem.github.io" |
| 16 | LICENSE = "LGPLv2.1" |
| 17 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24" |
| 18 | |
| 19 | SRC_URI[sha256sum] = "5df0af28f81891a3914a12f3a30b11b1981f7b30e09c5a42c011797e7fce9b6a" |
| 20 | |
| 21 | inherit pypi setuptools3 update-alternatives |
| 22 | |
| 23 | DEPENDS += " \ |
| 24 | ${PYTHON_PN}-ply-native \ |
| 25 | ${PYTHON_PN}-pyyaml-native \ |
| 26 | ${PYTHON_PN}-six-native \ |
| 27 | ${PYTHON_PN}-wheel-native \ |
| 28 | " |
| 29 | |
| 30 | RDEPENDS:${PN}:class-target += "\ |
| 31 | ${PYTHON_PN}-datetime \ |
| 32 | ${PYTHON_PN}-io \ |
| 33 | ${PYTHON_PN}-netclient \ |
| 34 | ${PYTHON_PN}-ply \ |
| 35 | ${PYTHON_PN}-pyyaml \ |
| 36 | ${PYTHON_PN}-six \ |
| 37 | ${PYTHON_PN}-stringold \ |
| 38 | ${PYTHON_PN}-threading \ |
| 39 | ${PYTHON_PN}-unixadmin \ |
| 40 | ${PYTHON_PN}-xml \ |
| 41 | ${PYTHON_PN}-nocasedict \ |
| 42 | ${PYTHON_PN}-nocaselist \ |
| 43 | ${PYTHON_PN}-yamlloader \ |
| 44 | " |
| 45 | |
| 46 | ALTERNATIVE:${PN} = "mof_compiler" |
| 47 | ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler" |
| 48 | |
| 49 | ALTERNATIVE_PRIORITY = "60" |
| 50 | |
| 51 | BBCLASSEXTEND = "native" |