blob: 9a1c591b2766919c9e9543fa371662a4f8c07967 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A parallel implementation of gzip"
2DESCRIPTION = "pigz, which stands for parallel implementation of gzip, is a \
3fully functional replacement for gzip that exploits multiple processors and \
4multiple cores to the hilt when compressing data. pigz was written by Mark \
5Adler, and uses the zlib and pthread libraries."
6HOMEPAGE = "http://zlib.net/pigz/"
7SECTION = "console/utils"
8LICENSE = "Zlib & Apache-2.0"
9LIC_FILES_CHKSUM = "file://pigz.c;md5=9ae6dee8ceba9610596ed0ada493d142;beginline=7;endline=21"
10
11SRC_URI = "http://zlib.net/${BPN}/fossils/${BP}.tar.gz"
12SRC_URI[sha256sum] = "b4c9e60344a08d5db37ca7ad00a5b2c76ccb9556354b722d56d55ca7e8b1c707"
13PROVIDES:class-native += "gzip-native"
14
15# Point this at the homepage in case /fossils/ isn't updated
16UPSTREAM_CHECK_URI = "http://zlib.net/${BPN}/"
17UPSTREAM_CHECK_REGEX = "pigz-(?P<pver>.*)\.tar"
18
19DEPENDS = "zlib"
20
21EXTRA_OEMAKE = "-e MAKEFLAGS="
22
23inherit update-alternatives
24
25do_install() {
26 # Install files into /bin (FHS), which is typical place for gzip
27 install -d ${D}${base_bindir}
28 install ${B}/pigz ${D}${base_bindir}/pigz
29 ln -nsf pigz ${D}${base_bindir}/unpigz
30 ln -nsf pigz ${D}${base_bindir}/pigzcat
31}
32
33do_install:append:class-native() {
34 install -d ${D}${bindir}
35 install ${B}/pigz ${D}${bindir}/gzip
36 ln -nsf gzip ${D}${bindir}/gunzip
37 ln -nsf gzip ${D}${bindir}/zcat
38}
39
40ALTERNATIVE_PRIORITY = "110"
41ALTERNATIVE:${PN} = "gunzip gzip zcat"
42ALTERNATIVE:${PN}:class-nativesdk = ""
43ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
44ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
45ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
46ALTERNATIVE_TARGET = "${base_bindir}/pigz"
47
48BBCLASSEXTEND = "native nativesdk"