blob: 400f9df09cb26104bc01dac8b98c1aa9100ac65d [file] [log] [blame]
Patrick Rudolph4ea73932023-05-03 11:14:33 +02001FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
2inherit systemd
3inherit obmc-phosphor-systemd
4
5SRC_URI += " \
6 file://phosphor-multi-gpio-presence.json \
7 file://dependencies.conf \
8 "
9
10FILES:${PN}-presence += " ${datadir}/${PN}/phosphor-multi-gpio-presence.json \
11 ${systemd_system_unitdir}/phosphor-multi-gpio-presence.service.d/dependencies.conf \
12 "
13
14do_install:append() {
15 rm -f ${D}${datadir}/${PN}/phosphor-multi-gpio-presence.json
16 install -m 0644 ${WORKDIR}/phosphor-multi-gpio-presence.json ${D}${datadir}/${PN}/
17 install -d ${D}${systemd_system_unitdir}/phosphor-multi-gpio-presence.service.d/
18 install -m 644 -D ${WORKDIR}/dependencies.conf ${D}${systemd_system_unitdir}/phosphor-multi-gpio-presence.service.d/dependencies.conf
19}