William A. Kennington III | 0decde1 | 2022-02-08 16:24:42 -0800 | [diff] [blame] | 1 | SUMMARY = "Google DHCP completion daemon" |
| 2 | DESCRIPTION = "Google DHCP completion daemon" |
| 3 | GOOGLE_MISC_PROJ = "dhcp-done" |
| 4 | |
| 5 | require ../google-misc/google-misc.inc |
| 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | SYSTEMD_SERVICE:${PN} += "dhcp-done.service" |
| 10 | |
| 11 | DEPENDS += " \ |
| 12 | sdeventplus \ |
| 13 | stdplus \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI += "file://50-dhcp-done.rules" |
| 17 | FILES:${PN} += "${sysconfdir}/nftables" |
| 18 | do_install:append() { |
| 19 | nftables_dir=${D}${sysconfdir}/nftables |
| 20 | install -d -m0755 "$nftables_dir" |
| 21 | install -m0644 ${WORKDIR}/50-dhcp-done.rules $nftables_dir/ |
| 22 | } |