blob: d11b083e8b94ab07747d5151991bc77581acbff1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
8 file://hash.c;beginline=6;endline=15;md5=96f7296605eae807670fb08947829969 \
9 file://list.c;beginline=4;endline=13;md5=cdbfa3dee51c099edb04e39f762ee907 \
10 file://trio.c;beginline=5;endline=14;md5=6c025753c86d958722ec76e94cae932e"
11
12DEPENDS = "zlib virtual/libiconv"
13
14SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
16 file://libxml-64bit.patch \
17 file://runtest.patch \
18 file://run-ptest \
19 file://python-sitepackages-dir.patch \
20 file://libxml-m4-use-pkgconfig.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
23 file://CVE-2020-7595.patch \
24 file://CVE-2019-20388.patch \
25 "
26
27SRC_URI[libtar.md5sum] = "10942a1dc23137a8aa07f0639cbfece5"
28SRC_URI[libtar.sha256sum] = "aafee193ffb8fe0c82d4afef6ef91972cbaf5feea100edc2f262750611b4be1f"
29SRC_URI[testtar.md5sum] = "ae3d1ebe000a3972afa104ca7f0e1b4a"
30SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
31
32BINCONFIG = "${bindir}/xml2-config"
33
34PACKAGECONFIG ??= "python \
35 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
36"
37PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
38PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
39
Andrew Geissler5a43b432020-06-13 10:46:56 -050040inherit autotools pkgconfig binconfig-disabled ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050041
42inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3native', '', d)}
43
44RDEPENDS_${PN}-ptest += "make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
45
46RDEPENDS_${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
47
48RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-gconv-ebcdic-us \
49 glibc-gconv-ibm1141 \
50 glibc-gconv-iso8859-5 \
51 glibc-gconv-euc-jp \
52 locale-base-en-us \
53 "
54
55export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
56
57# WARNING: zlib is required for RPM use
58EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
59EXTRA_OECONF_class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
60EXTRA_OECONF_class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
61EXTRA_OECONF_linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
62
63python populate_packages_prepend () {
64 # autonamer would call this libxml2-2, but we don't want that
65 if d.getVar('DEBIAN_NAMES'):
66 d.setVar('PKG_libxml2', '${MLPREFIX}libxml2')
67}
68
69PACKAGE_BEFORE_PN += "${PN}-utils"
70PACKAGES += "${PN}-python"
71
72FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
73FILES_${PN}-dev += "${libdir}/xml2Conf.sh ${libdir}/cmake/*"
74FILES_${PN}-utils = "${bindir}/*"
75FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
76
77do_configure_prepend () {
78 # executables take longer to package: these should not be executable
79 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
80}
81
82do_compile_ptest() {
83 oe_runmake check-am
84}
85
86do_install_ptest () {
87 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
88 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
89 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
90 ${D}${PTEST_PATH}/python/tests/Makefile
91 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
92 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
93 fi
94 #Remove build host references from various Makefiles
95 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
96 sed -i \
97 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
98 -e 's|${DEBUG_PREFIX_MAP}||g' \
99 -e 's:${HOSTTOOLS_DIR}/::g' \
100 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
101 -e 's:${RECIPE_SYSROOT}::g' \
102 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
103 -e '/^RELDATE/d' \
104 {} +
105}
106
107do_install_append_class-native () {
108 # Docs are not needed in the native case
109 rm ${D}${datadir}/gtk-doc -rf
110}
111
112BBCLASSEXTEND = "native nativesdk"