blob: 97ce44995467ab8c071379c9d714dbccce11ed51 [file] [log] [blame]
Brad Bishop6e60e8b2018-02-01 10:27:11 -05001# dosfstools OE build file
2# Copyright (C) 2004-2006, Advanced Micro Devices, Inc. All Rights Reserved
3# Copyright (C) 2015, Sören Brinkmann <soeren.brinkmann@gmail> All Rights Reserved
4# Released under the MIT license (see packages/COPYING)
5SUMMARY = "DOS FAT Filesystem Utilities"
6HOMEPAGE = "https://github.com/dosfstools/dosfstools"
7
8SECTION = "base"
9LICENSE = "GPLv3"
10LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
11
12SRC_URI = "https://github.com/dosfstools/dosfstools/releases/download/v${PV}/${BP}.tar.xz \
13 "
14SRC_URI[md5sum] = "07a1050db1a898e9a2e03b0c4569c4bd"
15SRC_URI[sha256sum] = "e6b2aca70ccc3fe3687365009dd94a2e18e82b688ed4e260e04b7412471cc173"
16
17UPSTREAM_CHECK_URI = "https://github.com/dosfstools/dosfstools/releases"
18
19inherit autotools pkgconfig
20
21EXTRA_OECONF = "--without-udev --enable-compat-symlinks"
22
23CFLAGS += "-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64"
24
Andrew Geissler5a43b432020-06-13 10:46:56 -050025BBCLASSEXTEND = "native nativesdk"
Andrew Geissler82c905d2020-04-13 13:39:40 -050026
27# Add codepage437 to avoid error from `dosfsck -l`
28RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-ibm437"