blob: 2d9cac830ed34d697e9b6711845e33c50ab6fcee [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A library providing C and Python (libcURL like) API \
2 for downloading linux repository metadata and packages."
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRC_URI = "git://github.com/rpm-software-management/librepo.git \
7 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
8 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
9 "
10
Andrew Geissler5a43b432020-06-13 10:46:56 -050011SRCREV = "9c173f1110bb30f4ae842a8e3532b275966c2d83"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012
13S = "${WORKDIR}/git"
14
15DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
16
17inherit cmake distutils3-base pkgconfig
18
19EXTRA_OECMAKE = " \
20 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
21 -DPYTHON_DESIRED=3 \
22 -DENABLE_TESTS=OFF \
23 -DENABLE_DOCS=OFF \
24 -DWITH_ZCHUNK=OFF \
25"
26
27BBCLASSEXTEND = "native nativesdk"