blob: 4f0f9531a1579d5df14ab41da0d64289d663f5ee [file] [log] [blame]
Andrew Geissler5a43b432020-06-13 10:46:56 -05001SUMMARY = "Socket-based service activation daemon"
2HOMEPAGE = "https://github.com/xinetd-org/xinetd"
3
4# xinetd is a BSD-like license
5# Apple and Gentoo say BSD here.
6LICENSE = "BSD"
7LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=55c5fdf02cfcca3fc9621b6f2ceae10f"
8
9UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
10
11SRC_URI = "git://github.com/openSUSE/xinetd.git;protocol=https \
12 file://xinetd.init \
13 file://xinetd.default \
14 file://xinetd.service \
15 "
16
17SRCREV = "6a4af7786630ce48747d9687e2f18f45ea6684c4"
18
19S = "${WORKDIR}/git"
20
21inherit autotools update-rc.d systemd pkgconfig
22
23SYSTEMD_SERVICE_${PN} = "xinetd.service"
24
25INITSCRIPT_NAME = "xinetd"
26INITSCRIPT_PARAMS = "defaults"
27
28PACKAGECONFIG ??= "tcp-wrappers"
29PACKAGECONFIG[tcp-wrappers] = "--with-libwrap,,tcp-wrappers"
30
31CONFFILES_${PN} = "${sysconfdir}/xinetd.conf"
32
33do_install_append() {
34 install -d "${D}${sysconfdir}/init.d"
35 install -d "${D}${sysconfdir}/default"
36 install -m 755 "${WORKDIR}/xinetd.init" "${D}${sysconfdir}/init.d/xinetd"
37 install -m 644 "${WORKDIR}/xinetd.default" "${D}${sysconfdir}/default/xinetd"
38
39 # Install systemd unit files
40 install -d ${D}${systemd_unitdir}/system
41 install -m 0644 ${WORKDIR}/xinetd.service ${D}${systemd_unitdir}/system
42 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
43 -e 's,@SBINDIR@,${sbindir},g' \
44 ${D}${systemd_unitdir}/system/xinetd.service
45}
46
47RDEPENDS_${PN} += "perl"