blob: 9484f010c0a30ce4ca0859ff800cad1c1d809574 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "Collection of Vulkan examples"
2LICENSE = "MIT"
3DEPENDS = "zlib"
4
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=dcf473723faabf17baa9b5f2207599d0 \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006 file://examples/triangle/triangle.cpp;endline=12;md5=bccd1bf9cadd9e10086cf7872157e4fa"
7
Andrew Geissler82c905d2020-04-13 13:39:40 -05008SRCREV_glm = "1ad55c5016339b83b7eec98c31007e0aee57d2bf"
Andrew Geisslerc182c622020-05-15 14:13:32 -05009SRCREV_ktx = "726d14d02c95bb21ec9e43807751b491d295dd3c"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
11SRC_URI = "git://github.com/SaschaWillems/Vulkan.git \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012 git://github.com/g-truc/glm;destsuffix=git/external/glm;name=glm \
Andrew Geisslerc182c622020-05-15 14:13:32 -050013 git://github.com/KhronosGroup/KTX-Software;destsuffix=git/external/ktx;name=ktx;lfs=0 \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050014 file://0001-Don-t-build-demos-with-questionably-licensed-data.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 "
Brad Bishop316dfdd2018-06-25 12:45:53 -040016UPSTREAM_CHECK_COMMITS = "1"
Andrew Geissler5a43b432020-06-13 10:46:56 -050017SRCREV = "4818f85916bf88c1ca8c2ed1a46e0e758651489e"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050018UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
19S = "${WORKDIR}/git"
20
21REQUIRED_DISTRO_FEATURES = 'vulkan'
22
Brad Bishop6dbb3162019-11-25 09:41:34 -050023inherit cmake features_check
Andrew Geissler82c905d2020-04-13 13:39:40 -050024DEPENDS = "vulkan-loader assimp wayland-protocols wayland-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050025
26do_install_append () {
27 # Remove assets that have uncertain licenses
28 rm ${D}${datadir}/vulkan-demos/models/armor/* \
29 ${D}${datadir}/vulkan-demos/models/sibenik/* \
30 ${D}${datadir}/vulkan-demos/models/vulkanscene* \
31 ${D}${datadir}/vulkan-demos/models/plants.dae \
32 ${D}${datadir}/vulkan-demos/textures/texturearray_plants*
33
34 mv ${D}${bindir}/screenshot ${D}${bindir}/vulkan-screenshot
35}
36
37EXTRA_OECMAKE = "-DRESOURCE_INSTALL_DIR=${datadir}/vulkan-demos"
38
39ANY_OF_DISTRO_FEATURES = "x11 wayland"
40
41# Can only pick one of [wayland,xcb]
42PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'xcb' ,d)}"
43PACKAGECONFIG[wayland] = "-DUSE_WAYLAND_WSI=ON, -DUSE_WAYLAND_WSI=OFF, wayland"
44PACKAGECONFIG[xcb] = ",,libxcb"